Become a Site Supporter and Never see Ads again!

Author Topic: Tascam DR 680 mkI - no input  (Read 446 times)

0 Members and 1 Guest are viewing this topic.

Offline Bdumaguina

  • Trade Count: (0)
  • Taperssection Newbie
  • *
  • Posts: 1
Tascam DR 680 mkI - no input
« on: May 15, 2017, 05:07:53 PM »
Hello,

One of my location soundmen accidentally used an improper voltage setting on the power supply (powergorilla - used 16V instead of 12V). The unit powered up fine but we were not getting any input on any of the 6 channels, line or mic input. Upon checking the battery I immediately switched off the device.

Set the proper input voltage setting (12V), but the unit would not power up - an error message keeps appearing - SYSTEM ROM ERR
Switched to the included 12V power supply, still the same SYSTEM ROM ERR

After updating the Firmware  to v1.31 the unit powered up okay.
BUT I am still not getting any input on any of the 6 channels; MIC or LINE input; LOW or HIGH gain, phantom ON or OFF.
I also noticed that I am now unable to change the DATE/TIME. Other than this, I am able to access all menu settings and record into the SD card. Although I'm just recording blanks.
Lastly, I noticed that when I power down the unit - and then power it up a second time - I will get a SYSTEM ROM ERROR again. The third time I power it up the unit will power up fine, but all my settings (rec settings, pan settings, I/O, pre rec, etc) will revert back to settings similar to when the unit is INITIALIZED.

Customer Support is not responding to my inquiry regarding repairs.

Is the input section fried? Will a busman audio mod fix it?
Maybe a capacitor is busted somewhere that can be replaced?
Has anyone had similar experience and found a way to repair this problem?

Thank you,
Bryan

Offline goodcooker

  • Trade Count: (23)
  • Needs to get out more...
  • *****
  • Posts: 2152
  • Gender: Male
  • goes to 11
Re: Tascam DR 680 mkI - no input
« Reply #1 on: May 16, 2017, 07:34:55 AM »
In the early days of using this device in the field a bunch of people found out the hard way that over powering it will fry the board. This came as a surprise when people found out that batteries that would automatically determine the needed voltage would cycle through all the available voltages before settling on the one that was appropriate. Introducing 16V or 19V with these batteries even for a second cooked the device. If I remember correctly there is no fuse or relay to prevent damage.

Tascam authorized repair is very likely your only recourse.

If yours powers up at least there is some hope that it's not a brick.
MK41 > PFA > Aerco MP2/RAD MS2 > DR60d/DR2d
MBHO KA300 > Naiant PFA > SD MixPre6 (currently under construction)

http://www.archive.org/bookmarks/goodcooker

"Are you the Zman?" - fan at Panic 10-08-10 Kansas City

"I don't know who left this perfectly good inflatable wook doll here, but if I'm blowing her up, I'm keeping her." -  hoppedup

 

RSS | Mobile
Page created in 0.073 seconds with 24 queries.
© 2002-2017 Taperssection.com
Powered by SMF
Website Design by Foxtrot Media, Inc., a Baltimore Website Company