Become a Site Supporter and Never see Ads again!

Author Topic: Solved: Power Supply Capacitor - Help Requested  (Read 2029 times)

0 Members and 1 Guest are viewing this topic.

Offline Moke

  • Trade Count: (2)
  • Needs to get out more...
  • *****
  • Posts: 4048
  • caught and released 12 of them, ^
Solved: Power Supply Capacitor - Help Requested
« on: July 09, 2010, 09:31:06 PM »
Greetings,

I have an old turntable that I've taken on as a restoration effort.  Its well made, and worth spending some time on (but I'd rather not spend much $$, as I'd like to keep it a low budget sleeper build).
The power supply is built to handle both 50hz and 60hz supplies. It is changed at a switch below the platter.

The power input comes into a capacitor that has four poles, and variable capacitance, which I assume make up the difference for the variable supply rate.

When I turn the deck on, it fires right up, and gets to speed.  After a relatively short period time, about 15 seconds, the motor starts to slow down, to a point at after about 30 seconds it no longer turns, but you can feel the motor is still energized. By one minute the motor is not longer even energized and feels dead.
My assumption:
This cap can keep its spec for the time that I mentioned, in seconds, then starts losing its ability to supply the voltage to keep the motor going. As the voltage fades, the motor slows, and eventually not enough voltage is supplied to even excite it.
I poked around the capacitor, and, the 50/60hz switch, and cannot find anything over microvoltages with my DMM, so I suspect its the capacitor, as its the only thing of any kind of electronics in the power supply line.
The motor is rated at 90v->120vac, and 50/60hz
The deck is from 1964, as is this cap. Its a Shizuki RMP, with four taps on it.

Any help is appreciated. I do not even know what to call this capacitor, as its so different from what I know of as standard caps. So I cannot even look for replacements, as I do  not know what its called.

silver can - Shizuki RMP ("P" is obscured by the flash):


smaller cap, piggy backing on larger silver can:


motor mount and electronics:

The white wire that is cut-off, between the motor and mount plate, leads to the 50/60hz switch

thanks for hearing me out!
« Last Edit: July 12, 2010, 01:03:52 PM by mfrench »
Sent From My Craftsman Garage Door Opener

Offline Moke

  • Trade Count: (2)
  • Needs to get out more...
  • *****
  • Posts: 4048
  • caught and released 12 of them, ^
Re: Power Supply Capacitor - Help Requested
« Reply #1 on: July 09, 2010, 09:52:19 PM »
The incoming 110v is the brown cable.

here is a better pic of the cap, and wiring;
capacitor and motor:


close-up capacitor top:


« Last Edit: July 11, 2010, 11:22:32 AM by mfrench »
Sent From My Craftsman Garage Door Opener

Offline Moke

  • Trade Count: (2)
  • Needs to get out more...
  • *****
  • Posts: 4048
  • caught and released 12 of them, ^
Re: SOLVED: Power Supply Capacitor - Help Requested
« Reply #2 on: July 11, 2010, 07:13:52 PM »
Many thanks!

OK,.... I took my dremel and eviscerated the multi-layer capacitor today. I cut away the can, and I took a screwdriver, and chipped out the old wax from around the inner components (the two internal caps).
I was able to positively identify all the correct leads this way.

Yesterday, I went to the electronic supply house and bought the three various caps that I needed. The guys there took great care of me. I was helped by a guy that is a ham radio builder/operator, and he spoke the language very well.
I drilled a piece of plastic to hold the new caps, and, point to point wired an interpretation of the original circuit.

It worked!
Where I was barely able to get to 1050 motor speed with the OE cap in place, I'm now locked on at 1800 rpm motor speed (exactly where a turntable motor should run). And its been running at that speed for some time now in a workbench test run. I do not have the motor in the deck yet, nor the platter running, so I cannot get a platter speed, but as locked on at 1800 as I am, I'm sure there will be no problem with speed settings.

Its time to celebrate, as this was the big hurdle in getting this project off the ground.

« Last Edit: July 11, 2010, 07:16:12 PM by mfrench »
Sent From My Craftsman Garage Door Opener

 

RSS | Mobile
Page created in 0.07 seconds with 44 queries.
© 2002-2019 Taperssection.com
Powered by SMF