Become a Site Supporter and Never see Ads again!

Author Topic: V3 power plug problem  (Read 1804 times)

0 Members and 1 Guest are viewing this topic.

Offline Brian Skalinder

  • Complaint Dept.
  • Trade Count: (27)
  • Needs to get out more...
  • *****
  • Posts: 18660
  • Gender: Male
V3 power plug problem
« on: June 27, 2003, 11:53:29 AM »
Does your V3 intermittently lose power when it's moved, you jiggle the cable/connector, or just plain won't power up?

I had the same problem and found the solution on the Oade board by someone who'd spoken with Grace about it.

If you look at the female power plug built into the V3, you'll see there's a pair of pins in the center of the plug.  Over time, these two pins get pushed together a bit, and therefore don't have solid/consistent contact with the inserted power plug.

To resolve the problem, very gently use a small glasses-type screwdriver or some such to pry the 2 pins apart just a bit.  It doesn't take much.  This should provide sufficient contact and reliable power.

(Don't snap the pins!  If you do, you're hosed.  Don't wanna scare you, it actually isn't very easy to break 'em as long as you're careful, just trying to emphasize - be careful.)

Offline stober

  • Trade Count: (16)
  • Taperssection All-Star
  • ****
  • Posts: 1557
  • Gender: Male
Re: V3 power plug problem
« Reply #1 on: August 20, 2005, 10:42:34 AM »
A toothpick works great.Just be gental

Offline not logged in

  • Trade Count: (0)
  • Taperssection Regular
  • **
  • Posts: 111
Re: V3 power plug problem
« Reply #2 on: August 20, 2005, 11:02:24 AM »
i had the same problem. 

i spoke to grace support about it, and they suggested self-repair with a toothpick (instead of sending in the v3).  i now always have a toothpick when i go to shows!

Offline jsfrank

  • Trade Count: (0)
  • Taperssection Member
  • ***
  • Posts: 783
  • Gender: Male
Re: V3 power plug problem
« Reply #3 on: July 08, 2009, 06:08:12 PM »
I have been having the same problem. I used a knife and was probably too careful. It fixed it for awhile. I'll try the toothpick. The cable I have is from Kind Kables. I was thinking of buying another cable from somewhere else, but I guess I would have the same problem? Is it safe to say other more expensive cables would have that same screw in plug? I e-mailed Sonic Sense a couple of days ago and haven't heard back. Are they still in business?
AKG 481,2 or 3 > V3 > Marantz PMD661 (16/44.1)

 

RSS | Mobile
Page created in 0.153 seconds with 32 queries.
© 2002-2017 Taperssection.com
Powered by SMF
Website Design by Foxtrot Media, Inc., a Baltimore Website Company