Become a Site Supporter and Never see Ads again!

Author Topic: Help with v1.10 Firmware update for Olympus LS-10. Can’t find it anywhere.  (Read 2810 times)

0 Members and 1 Guest are viewing this topic.

Offline Teppka

  • Trade Count: (0)
  • Taperssection Newbie
  • *
  • Posts: 29
Have just ordered Olympus LS-10 which apparently has version 1.10.
I checked old thread and all olympus download sources do not exist anymore. Olympus LS-10 product page which still seems to be live has no firmware files.
Chatting with support gave no results. Which is really strange, model may be old but there is a product page with user manual, why not leave firmware files there?

https://learnandsupport.getolympus.com/support/ls-10

I wander if anyone happen to have firmware 1.10 for this unit or can suggest where to look?
Thanks.

Offline Teppka

  • Trade Count: (0)
  • Taperssection Newbie
  • *
  • Posts: 29
Found it on Olympus Japan’s website. Had to use translator as it’s in japanese. Apparently the latest version is v1.20

Will leave this info here if anyone will need it.

Download for Windows: https://cs.olympus-imaging.jp/jp/support/cs/VT/softDL/J/ls10/ls10update.html
Download for Mac: https://cs.olympus-imaging.jp/jp/support/cs/VT/softDL/J/ls10/ls10update_mac.html

v1.10 to v1.20 main changes:

Added index function
・   SD card compatibility has been improved and the confirmed card list has been updated.
(The phenomenon that may occur on some SD cards, cannot be initialized, and the recorded file cannot be seen will be improved.)
For confirmed cards, please refer to the "LS-10 Confirmed SD/SDHC Memory Card List"
There is a link to the List of SD/SDHC memory cards that have been confirmed to work with LS-10

Please refer to "LS-10 FW Ver.1.20 Additional Features" for new functions added by firmware update.
there is a link on the page to document in Japanese with all details.


Offline GLouie

  • Trade Count: (0)
  • Taperssection Regular
  • **
  • Posts: 191
There seem to be several variants of the LS-10, as well as the LS-10S. I have an early unit that is firmware 1.04 and no instructions ever given for upgrading firmware - and it hasn't been buggy anyway as far as I could tell. It might've been nice to get SDXC capability and the 88.2 sample rate, but that was never a deal killer for me.

Is there a note on which serial numbers can take certain firmware updates?

Offline Teppka

  • Trade Count: (0)
  • Taperssection Newbie
  • *
  • Posts: 29
Japanese website as well as Olympus US website reads only one model - LS-10. I read somewhere that these are basically the same models and the only difference in what you get out of the box. I believe LS-10s is missing some PC software they include with LS-10 package. I didn’t receive my recorder yet but the seller said it has v1.00 as it was never used. And since I can’t find v1.10 anyways, v1.20 is the only option I have.
« Last Edit: May 30, 2023, 05:59:11 AM by Teppka »

Offline lpmaskman

  • Trade Count: (0)
  • Taperssection Regular
  • **
  • Posts: 122
  • Gender: Male
    • Trade list
I have LS-12 and I can't find firmware for it. It has 1.10 on it as I bought.
Mics: AT853, ATM35
Inbetween: CA-9100, 3-wire battery box (homemade)
Recorders: Olympus LS-12, Zoom H2 (4 channel line input mod)
Video: Panasonic HC-V770 (x2), GoPro Hero4 Silver, Sony RX10mkII

Offline Teppka

  • Trade Count: (0)
  • Taperssection Newbie
  • *
  • Posts: 29
Japanese website as well as Olympus US website reads only one model - LS-10. I read somewhere that these are basically the same models and the only difference in what you get out of the box. I believe LS-10s is missing some PC software they include with LS-10 package. I didn’t receive my recorder yet but the seller said it has v1.00 as it was never used. And since I can’t find v1.10 anyways, v1.20 is the only option I have.

I gave it a try to update to v1.20 which is the only available on their Japanese website, tried both Windows and Mac versions, the update program could never detect my LS-10. I wonder if you would consider to give it a try? Trying to understand of it’s the update program or my unit. Thanks.

Offline GLouie

  • Trade Count: (0)
  • Taperssection Regular
  • **
  • Posts: 191
No joy here.
My early LS-10 is firmware v1.04 (never updated IIRC). I just tried to use the OM Systems OM DVR Updater (Mac). The app installed, but but said this function is not available for the device, or some such, when I tried it with the LS-10 connected.

A pity, I found an old thread on the forum that mentioned everyone getting v1.10 but, of course those links don't work anymore. I suspect Olympus dropped a lot of balls when they split up. Even if someone kept the old updating software, you might need a vintage computer to run it.

I did not want to try using the Japanese site.

Offline Teppka

  • Trade Count: (0)
  • Taperssection Newbie
  • *
  • Posts: 29
Thanks for the update. I have an old Mac running High Sierra and it did open the v1.20 updater software, but it doesn’t seem to recognize when device is connected. Same happened to Windows one, opened it on an older notebook running XP and it did open just fine, but didn’t recognize connected LS-10 for some reason. It os frustrating indeed to see so many threads about v1.10 and no mirror to download ot today. I asked Olympus Japan to send me 1.10 assuming they have it as they have 1.20 on their website but no.

Offline Teppka

  • Trade Count: (0)
  • Taperssection Newbie
  • *
  • Posts: 29
Have just received reply from Olympus Japan about v1.20 update software:

Since the LS-10 was released in 2008 and has been discontinued for more than 10 years,
the Mac OS supported by the update is X 10.2.8 to 10.10, and Windows 2000 to 7.
Please try with a supported OS.


And a clear statement that they are unable to provide any more support on this topic.
Well at least we now know the system requirements for this update as this info wasn’t available on their website.

Offline GLouie

  • Trade Count: (0)
  • Taperssection Regular
  • **
  • Posts: 191
I keep a Mac capable of MacOS10.6.8, that is not a problem.

Are these updaters stand-alone installers? It seems the current system of using DVR Updater looks for the device and then looks for updates at OM Systems via the internet. And they obviously don't support discontinued product.

Offline Teppka

  • Trade Count: (0)
  • Taperssection Newbie
  • *
  • Posts: 29
Yes, there is a standalone v1.20 firmware update programs for both Mac and Windows and they are specific for each old recorder. 
Mac v1.20 update program for LS-10 is available for download here:

https://support.jp.omsystem.com/jp/support/cs/VT/softDL/J/ls10/ls10update_mac.html

You may need to use google or browser translation as the page is in Japanese. Once you agree to the term download will begin.

Offline Teppka

  • Trade Count: (0)
  • Taperssection Newbie
  • *
  • Posts: 29
Have just installed Windows 7 on my Mac using virtual machine. Updater app launches fine, LS-10 mounts fine but is not recognized by updater app. So same problem. It’s either device or what most probably is the case v120 update apps. In this case there would be no way for me to update unless I can find a v1.10 update app.

Interesting thing is firmware versions and update apps for LS-11 are different. I heard LS-10 and LS-11 are almost identical but I don’t think I’ll risk bricking my device trying to load LS-11 firmware.
« Last Edit: July 13, 2023, 10:12:23 AM by Teppka »

 

RSS | Mobile
Page created in 0.051 seconds with 35 queries.
© 2002-2024 Taperssection.com
Powered by SMF